[Tecnica] problemi con grub

Luigi per.gigi a aruba.it
Lun 13 Lug 2009 22:18:35 BST


roberto.volpini a valdelsa.net ha scritto:
> ho risolto facendo cos.....siccome il problema era proprio quello che hai scritto.....e non mi  possibile aggiornare il bios (quello montato  l'ultima versione disponibile per il mio asus a2h).....ho partizionato l'hd lasciando all'inizio 200mb senza allocazione poi ho installato winzozz in una partizione ntfs che era la prima dopo quella non allocata....e con il partizionatore di ubuntu a quei 200mb gli ho dato l'allocazione come /boot e la partizione ext3 di ubuntu come / .....finita l'installazione funziona tutto ottimamente....questo qui sotto  il mio disco:
> 
> Disco /dev/sda: 160.0 GB, 160041885696 byte
> 255 testine, 63 settori/tracce, 19457 cilindri
> Unit = cilindri di 16065 * 512 = 8225280 byte
> Identificativo disco: 0x00037091
> 
> Dispositivo Boot      Start         End      Blocks   Id  System
> /dev/sda1   *          26        2671    21253995    7  HPFS/NTFS
> /dev/sda2            2672       19244   133122622+  83  Linux
> /dev/sda3           19245       19457     1710922+  82  Linux swap / Solaris
> /dev/sda4               1          25      200781    5  Esteso
> /dev/sda5               1          25      200749+  83  Linux
> 
> Le voci nella tabella delle partizioni non sono nello stesso ordine del disco
> 
> 
> grazie infinite....
> 
> roberto 
> 
>> ----- Messaggio Originale -----
>> Da: Luigi <per.gigi a aruba.it>
>> A: Lista Tecnica del Siena Linux User Group <tecnica a liste.siena.linux.it>
>> Data: 12/07/2009 16:36
>> Oggetto: Re: [Tecnica] problemi con grub
>>
>> robi ha scritto:
>>> andiamo con ordine.....LBA  40008mb.....il disco  stato partizionato 
>>> con il partizionatore di ubuntu .....se pensi che il problema sia la 
>>> partizione dimmi come devo farla e poi ne riparliamo.... l'hd  160gb ed 
>>>  stato sostituito a quello originale da 40gb....grazie aspetto 
>>> ulteriori consigli...
>>>
>> Secondo me il problema  proprio nella sostituzione del disco: 40008Mb
>> sono circa 40Gb. In concreto il BIOS non vede tutto l'HD, quindi devi
>> trafficare un po' con il BIOS, o aggiornarlo se non pu vedere i 160Gb
>> _______________________________________________
>> Tecnica mailing list
>> Tecnica a liste.siena.linux.it
>> http://liste.siena.linux.it/cgi-bin/mailman/listinfo/tecnica
> 
> _______________________________________________
> Tecnica mailing list
> Tecnica a liste.siena.linux.it
> http://liste.siena.linux.it/cgi-bin/mailman/listinfo/tecnica
> 
> 

Non ho ben capito cosa tu abbia combinato, ma se funziona ok. Hai
provato a disabilitare LBA dal BIOS? Inoltre, se non usi programmi molto
particolari, Windows conviene installarlo in una macchina virtuale,
VirtualBox funziona benissimo, io avevo bisogno di Windows per i
programmi della macchina fotografica, ho usato questo sistema e tutto va
perfettamente.
Personalmente non faccio mai una partizione di boot separata, alla fine
pu far girare anche i santissimi, partiziono il disco per root
(10-15GB), swap (piccolina, dipende dalla memoria) e tutto il resto per
home; in questa ci sta molto comodo anche un "disco" per Windows in
VirtualBox


Maggiori informazioni sulla lista Tecnica