[Tecnica] dipendenze......

Paolo Sammicheli xdatap1 a siena.linux.it
Mar 16 Feb 2010 20:24:44 GMT


Alle 19:02 del 16/2/2010, robi ha scritto:
> purtroppo come avete detto non funziona (premesso che di solito  il 
> gestore pacchetti che installa le dipendenze), in questo caso le 
> risposte da shell sono queste:
> 
> robi a robi-laptop:~$ sudo apt-get install libglade2-dev
> Lettura della lista dei pacchetti in corso... Fatto
> Generazione dell'albero delle dipendenze in corso      
> Lettura delle informazioni di stato... Fatto    
> Alcuni pacchetti non possono essere installati. Questo pu voler
> dire che  stata richiesta una situazione impossibile oppure, se
> si sta usando la distribuzione "unstable", che alcuni pacchetti
> richiesti non sono ancora stati creati o rimossi da incoming.
<SNIP>
> se provo con gli altri pacchetti lo stesso......ora ho il dubbio che ci 
> siano dei problemi con i "repo" ma vanno bene......e il serpente 
> continua a mordersi la coda.....

A me funziona:

-----------------------------------------------------
x a bwing:~$ sudo apt-get install libglade2-dev
[sudo] password for x: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno inoltre installati:
  libxml2-dev
Pacchetti suggeriti:
  glade glade-gnome
I seguenti pacchetti NUOVI saranno installati:
  libglade2-dev libxml2-dev
0 aggiornati, 2 installati, 0 da rimuovere e 23 non aggiornati.
 necessario scaricare 830kB di archivi.
Dopo quest'operazione, verranno occupati 2703kB di spazio su disco.
Continuare [S/n]? 
Scaricare:1 http://it.archive.ubuntu.com karmic/main libxml2-dev 
2.7.5.dfsg-1ubuntu1 [745kB]
Scaricare:2 http://it.archive.ubuntu.com karmic/main libglade2-dev 1:2.6.4-1 
[85,8kB]
Recuperati 830kB in 4s (176kB/s)    
Selezionato il pacchetto libxml2-dev.
(Lettura del database... 287726 file e directory attualmente installati.)
Estrazione di libxml2-dev (da .../libxml2-dev_2.7.5.dfsg-1ubuntu1_i386.deb)...
Selezionato il pacchetto libglade2-dev.
Estrazione di libglade2-dev (da .../libglade2-dev_1%3a2.6.4-1_i386.deb)...
Elaborazione dei trigger per man-db...
Elaborazione dei trigger per doc-base...
Processing 1 added doc-base file(s)...
Registering documents with scrollkeeper...
Configurazione di libxml2-dev (2.7.5.dfsg-1ubuntu1)...
Configurazione di libglade2-dev (1:2.6.4-1)...
-----------------------------------------------------

Quindi hai *sicuramente* un casino con i repository. Che versione di Ubuntu 
usi? Controlla il source.list

Ciao
-- 
Paolo Sammicheli  
Email: xdatap1(at)siena.linux.it
Slug - Siena Linux User Group | http://www.siena.linux.it
- Do what you like. Like what you do -


Maggiori informazioni sulla lista Tecnica