[Tecnica] problemi HP dv6-6169sl: grafica ibrida, fingerprint, java

Edoardo Giomi edogiomi a yahoo.it
Gio 12 Gen 2012 13:11:42 GMT


ciao a tutti,
ho acquistato da pochi giorni un laptop HP Pavilion dv6-6169sl che ho 
upgradato ad 8 GB di RAM e dove ho installato Ubuntu 11.10 (oneiric).
Questo laptop presenta una grafica ibrida con Intel integrata e ATI HD 
6770M discreta.
Vi riporto alcuni problemi che sto incontrando.

1) il lettore di impronte biometriche non viene ancora riconosciuto 
nonostante abbia seguito questa procedura 
https://bugs.launchpad.net/ubuntu/+source/libfprint/+bug/285089?comments=all 
post 78 e seguenti

2) nonostante siano correttamente installati OpenDJK (6 e 7) ho problemi 
con Firefox a loggarmi su una VPN con Juniper Network Connect (ho 
temporaneamente risolto installando una macchina virtuale con Win7Pro e 
facendo il login da IE9+java)

3) ho l'impressione che la scheda grafica ATI non abbia mai funzionato; 
mi spiego:

3.1) caso driver open

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core 
Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: ATI Technologies Inc Whistler XT [AMD 
Radeon HD 6700M Series]

sudo lshw -c display | grep driver
configuration: driver=radeon latency=0
configuration: driver=i915 latency=0

attraverso il flag vgaswitcheroo riesco solo a fare il power-up e 
power-down della ATI ma non riesco a selezionarla (nel senso che i 
comandi echo DIS > oppure echo DDIS > non hanno alcun effetto).
riuscendo ad ottenere solo queste 2 configurazioni (interrogando cat 
/sys/kernel/debug/vgaswitcheroo/switch):

0:IGD:+:Pwr:0000:00:02.0
1:DIS:   :Pwr:0000:01:00.0

0:IGD:+:Pwr:0000:00:02.0
1:DIS:   :Off:0000:01:00.0


3.2) caso driver catalyst
Innanzitutto con i driver proprietari non si pu lanciare cat 
/sys/kernel/debug/vgaswitcheroo/switch in quanto vgaswitcheroo non viene 
caricato.
Ho installato catalyst via sito AMD; la procedura sembra andare a buon 
fine, infatti:

sudo lshw -c display | grep driver
configuration: driver=fglrx_pci latency=0
configuration: driver=i915 latency=0

tuttavia se lancio aticonfig da terminale ottengo:

aticonfig: No supported adapters detected

se lancio AMD catalyst control center (sia versione "utente" che 
"admin") da dash ottengo il pi verboso avviso:

Si  verificato un problema durante l'inizializzazione del Catalyst 
Control Center nell'edizione Linux. Le cause potrebbero essere le seguenti.

Non  installato alcun driver grafico AMD oppure il driver AMD non 
funziona correttamente.

Pregasi installare il controllore AMD adatto al vostro hardware AMD o di 
configurarlo usando anticonfig.



Avete qualche suggerimento in merito ai punti precedenti?
Scusate se ho commesso qualche errore nel testo oppure non mi sono 
espresso bene, ma non sono n un programmatore n un ing. informatico.
solo un semplice linux user ;-)
grazie in anticipo,

edoardo






---------------------------------------------
Dott. Ing. Edoardo Giomi
V.le G. Mazzini, 24 - 53100 SIENA
Tel.: +39-0577-2237620
Mobile: +39-333-4335551
Fax.: +39-0577-223762
Private: edogiomi a yahoo.it
Work: edoardo.giomi a maxim-ic.com
---------------------------------------------
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://liste.siena.linux.it/pipermail/tecnica/attachments/20120112/1dc3e5a2/attachment.htm>


Maggiori informazioni sulla lista Tecnica