[Tecnica] Problema path autocomplete in SSH

Angelo Polvanesi polva86 a gmail.com
Mer 25 Giu 2014 19:54:30 BST


Salve lista.
Io ed il mio amico bartrosso oggi abbiamo avuto degli strani problemi con
un serverino OpenMediaVault (ultima release) l dove lavora.
In poche parole, lo stavo aiutando a preparare dei backup delle postazioni
con rsync. Praticamente il serverino OMV accede con un
*rsync -Pavze ssh user a remotodabackuppare://cartella/remota
/media/disco/cartellalocale*
e fa un pull dei dati. Ovviamente ho prima copiato le chiavi pubbliche del
mio user del server OMV sull'host da backuppare per autenticarmi.
Ho notato, per che l'autocomplete sull'rsync via ssh non funzionava,
mentre dal mio portatile di prova (Ubuntu 12.04LTS) autenticato alla stessa
maniera si.
Non credo che ci siano problemi di autenticazione dato che con ssh
user a remotodabackuppare entravo tranquillamente.
Ho provato per una mezz'oretta, controllando attentamente percorsi, ip e
sintassi, ma non c' stato verso. Il problema  che non copiava nemmeno i
dati, restituendo un errore.
Sono andato a mangiare un boccone e al tentativo successivo,
aleatoriamente, mi verrebbe da dire, funzionava, sia l'autocomplete che la
copia.
Il problema lo ha manifestato collegandosi con un iMac e un'altro computer
con Ubuntu.
Questo episodio mi ha fatto tornare anche in mente che in passato avevo
riavuto problemi simili e quindi vi volevo chiedere: vi  mai capitato?
Sapete quello che potrebbe essere? Vorrei evitare che risucceda.
Grazie e buona serata.
Il Polva.
-------------- parte successiva --------------
Un allegato HTML  stato rimosso...
URL: <http://liste.siena.linux.it/pipermail/tecnica/attachments/20140625/dd27c239/attachment.htm>


Maggiori informazioni sulla lista Tecnica